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Introduction

VisTrails Provenance Explorer for ParaView is a unique tool that allows interaction 
between different stages in the design process.  A completely interactive visual trail (or 
vistrail) is transparently created while a user interacts with the ParaView system.  The 
vistrail is much more than a simple history log— the contents are displayed in a 
branching version tree that can be browsed, annotated, queried,  analyzed, and re-used. 
VisTrails’ provenance technology makes it possible to maintain the important decisions 
and steps that are used to create a digital asset along with the final result.  This is 
especially useful for the transfer of knowledge and expertise from one user to the next.
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Getting Started

Editions

VisTrails Provenance Explorer is available at www.vistrails.com/paraview.html

Installation

System Requirements: VisTrails Provenance Explorer requires ParaView-3.6.2 to be 
installed on a Windows platform (XP/Vista/7) or Linux and is available in 32 and 64 
bit.  

1. Download ParaView from www.paraview.org/paraview/resources/software.html

2. Windows Installation:  Run the  Windows Installer.

 a. Windows Vista: Right click on the .exe setup file and select “Run as 
administrator”


b. Windows XP: Log in as administrator and execute the .exe setup file

3. Initialize the plug-in by opening ParaView and selecting the Tools → Manage 
Plugins/Extensions →  Load menu item, and clicking on the Load button in the 
Plugin Manager box.  In the Load Plugin pop up box select bin → plugins → 
VisTrailsPlugin → VisTrailsPlugin.dll.  After selecting the VisTrailsPlugin.dll, the 
plugin will be started and the Plugin Manager box can be closed.

4. Linux Installation: 
a. Untar paraview-3.6.2-Linux32-x86.tar.gz

b. Execute Paraview from the bin folder.

c. Initialize the plug-in by selecting Tools → Manage Plugins/Extensions.  In the 
Load Plugin pop up box select bin → Plugins → VisTrailsPlugin → lib → 
VisTrailsPlugin.so
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The Plug-in Interface
The plug-in consists of the following components:
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Interacting with the Version Tree
The Version Tree is a visual representation of all the operations that a user performs in 
ParaView.  The Tree is completely interactive, allowing all versions of the scene to be 
recreated by simply selecting a version.  Branches form in the tree after undo operations 
or when the user selects a previous version in the Tree and continues to work in 
ParaView from that version.  Here we describe some of the interactions that are possible 
wit the plug-in for navigating and annotating the Version Tree.

Navigating

Select: Versions can be selected in the Version Tree using the Select tool located on the 
toolbar at the top of the plug-in.  The ParaView display will be updated to reflect the 
state of the scene when the selected version was created.  By default, the camera settings 
and panel layouts in Paraview change when selecting versions in the Tree to reflect the 
settings that were used during recording.  To change this behavior, the Lock View 
toolbar item can be enabled and the camera and panel layouts will remain static during 
navigation.

Pan/Zoom: The Version Tree Canvas can be interactively navigated using the Pan and 
Zoom tools on the toolbar, or alternatively, by clicking and dragging the middle mouse 
button (Pan) or the right mouse button (Zoom) in the Canvas.  The mouse scroll wheel 
can also be used to Zoom the Version Tree.  To set the view of the Version Tree to show 
all versions, the View → Frame All menu item can be selected.  Similarly, to zoom into 
the current selection, the View → Frame Selection menu item can be selected.

Undo/Redo: Undo and redo can be performed in the plug-in using the Ctrl+z and Shift
+z shortcuts, respectively, or by selecting the Undo and Redo buttons from the top 
toolbar. Undo in Paraview and the plugin are synchronized so that the operation moves 
the current version up one version in the Tree and redo moves the current version back 
down to the version that was undone. 

Expand/Collapse: The Version Tree automatically collapses intermediate steps to reduce 
the clutter of a large Tree. Expanding and Collapsing the Tree to view intermediate steps 
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can be performed in several ways. The easiest is by selecting the Expand or Collapse 
buttons directly on the Canvas. Menu items View → Expand Branch and View → 
Collapse Branch operate on the versions in the same branch of the Tree as the current 
version. View → Collapse All will collapse the entire Tree into its smallest form. By 
default, the most recently created versions are not collapsed in the Version Tree, as 
specified by the Number of Visible Versions preference accessed via the Edit → 
Preferences menu item.

Hide/Show: The Version Tree maintains all the operations a user performs. However, 
there are cases where a user may perform a series of erroneous steps in Paraview and 
desire to back up using undo and continue working with the correct steps. An 
undesired branch in the Tree, such as one created by the scenario described, can be 
hidden by selecting the highest version in the branch and selecting View → Hide 
Branch. The View → Show All menu item will restore all hidden branches.

Annotating

Useful metadata is captured automatically by the plug-in and displayed in the plug-in’s 
Heads Up Display.  This metadata refers to the current version and is updated when a 
new version is selected. Static information for each version includes the name of the 
user that performed the operation, the time and date the operation was performed, and 
action and details strings that describe the operation. By default the metadata is 
truncated to reduce the size in the display. By hovering the mouse over an item, a tool-
tip will appear showing the full content.

Optional annotations can also be added to any version by the user.

Tags: A tag is a user specified string that bookmarks important versions in the Tree. 
Tagged versions are never collapsed and are thus always easily accessible. A tag 
replaces the action text that is displayed in the center of a version. To add or edit a tag, 
simply double click on a selected version and type the tag into the edit box that is 
displayed.

Notes: Additional information, in the form of notes, can be added to a version to assist in 
understanding the operation that was performed or give insight into the creation 
process. Editing the notes for a version is performed by selecting the + symbol in the 
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Notes section of the Heads Up Display. This opens a dialog that allows a full set of notes 
to be entered. The first few words of the notes are then displayed in the Heads Up 
Display to indicate that there are notes associated with the current version.

File Handling

A vistrail is stored as a .vt file that contains the provenance information to recreate each 
step that was used in the creation of a scene in Paraview. By default, any Paraview 
scenes that are opened or imported are incorporated into the vistrail so it can be 
recreated from the vistrail alone (see Preferences). A vistrail is associated with a 
Paraview Project in the same way a Paraview scene is. Any textures, or other files that 
are not included in a Paraview scene file are also not included in a vistrail. Thus, as with 
a scene, a full project should be distributed with a vistrail if external texture files or 
caches are referenced or created.

Vi s Tr a i l s ,  I n c .
 P r o v e n a n c e  E x p l o r e r  f o r  P a r a Vi e w

8



Tools

VisTrails Provenance Explorer contains several additional tools to assist in the capture, 
analysis, and reuse of provenance. These tools are described in detail here.

Time Statistics

Statistics can be generated using the metadata that is associated with each version in the 
Version Tree.
The plug-in includes one such statistic for computing the amount of time that has been 
spent on the scene. Compute Statistics will compute and display the time that each user 
spent on a vistrail or on a series of steps in a vistrail. This time is calculated for active 
sessions and ignores the time between sessions.  To compute statistics for the entire 
vistrail, the Tools → Compute Statistics menu item is used.  To compute statistics for a 
sequence of operations in the Tree, the Tools → Compute Sequence Statistics... menu 
item is used. This latter tool prompts the user via the status bar to select two versions 
from the tree. After the selection is made, a dialog will open that shows the time spent 
per user on the actions that occurred between the two selected versions. Closing the 
Time Statistics dialog will return the plug-in to an operational state.

Search

The Tags, Actions, Users, Date, and Notes metadata can be queried using the Tools → 
Search tool. When the tool is activated, a panel is displayed that allows textual queries 
to be entered. Matching versions are highlighted in the Version Tree with the default 
Search setting from the Search Icon drop down menu. To hide all versions from the Tree 
that do not match, the Refine setting from the drop down menu can be used.

Playback

The playback tool allows the versions to be animated sequentially, giving an effect 
similar to a movie that was captured of the scene creation process. Selecting Tools → 
Playback opens the following playback panel at the bottom of the plug-in window.
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When the Playback panel is open, two versions in the Version Tree are given green and 
red indicators to show the start and end versions of the animation. By default, the root 
of the tree is the start version and the current is the end version. The Start/End Versions 
button in the panel allows the user to redefine these versions using a selection prompt. 
The animation can be started and paused using the Play/Pause button and reset to the 
start version using the Stop button. The Timeline indicates the current version of the 
animation and can be interactively moved to adjust the current version directly in the 
animation. The speed at which the versions are replayed can be defined using the 
Speed of Animation drop down menu. 
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Preferences

The following preferences are found in the dialog accessed by the Edit → Preferences 
menu item of the plug-in. Changes to the plug-in’s preferences are maintained with 
ParaView preferences.  

Number of recent versions visible: This drop down menu allows the user to specify the 
number of versions in the Version Tree that are shown before an automatic collapse 
operation is performed. 

Take state snapshots: This check box allows the user to disable snapshots from being 
performed automatically by the plug-in.

Number of actions between snapshots: This drop down menu specifies how frequently 
the automatic snapshots are taken.

Store opened and imported files in vistrail: The plug-in manages files in different ways, 
similar to ParaView’s Open/Import versus Reference functionality. If this check box is 
selected, any files opened or imported in ParaView will be copied into the vistrail file so 
that the vistrail is self-contained. If this check box is not selected, the files are all 
referenced and will need to be distributed along with a vistrail for it to be fully 
functional on another machine.

Plug-in window always on top: If checked, this option will keep the plug-in on top of 
any other ParaView windows so that it is always visible.
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Simple Tutorial

This section will guide you through a series of steps to navigate and modify an existing 
vistrails that models geometry within Paraview.

Navigating a Vistrails and Adding Annotations

1. Open ParaView and start the Provenance Explorer Plug-in by selecting Tools - Man-

age Plugins/Extensions - Load.  The VisTrails Plugin is under the following folder: 

bin → plugins → VisTrailsPlugin → VisTrailsPlugin.dll

2. In the ParaView main window, select File - Open and open the iron_protein.vtk file.

*Note: Protein.vtk is part of the ParaViewData folder which can be downloaded from: 
http://paraview.org/files/v3.6/ParaViewData3.6.zip

3. In ParaView Object Inspector Properties, click on Apply.

4. In the Display option, change the Representation Style to Volume.

5. In the VisTrails Provenance Explorer double click on the current 
version (highlighted in yellow) in the three.  This displays a text 
edit box. Clear the text in the box and type ‘Volume’ followed by 
the Return or Enter key.  

6. In the Provenance Explorer Plugin add a note by clicking on 
the + sign in the top left corner.  Once the Notes window 
pop-up, add the text “Volume created” and click on the Ap-
ply button, followed by the Okay button.

 The version you just created now has a tag and will always be 
shown in the tree.
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6. In the Paraview Object Inspector 
Window, click on Display Op-
tion - Edit Color Map button.  In 
the Color Scale Editor pop-up 
window, change the colors 
around by single clicking inside of the color box. In the Provenance Explorer Window, 
click on the current version (highlighted in yellow) in the tree, and rename it to 
“Transfer Function”.

7. In the Provenance Explorer, click on the first + sign of the tree.   And select 
the Apply version. 

8. In the ParaView menu, click on the Contour Icon followed by the  
Apply button in the Object Inspector Window.  Rename the last 
version tree in Provenance Explorer to Contour.  Now you have 
just created another path in the version tree.

9. Rename the current tree in Provenance Explorer to “Isosurface”.  
Back to the Paraview window, change the Value Range of the Isosurfaces to 100 by 
double-clicking on the value, and rename it to 100.  Next click on the New Value but-
ton and add two new values: 128 and 191 and clicking in the Apply button. 

10. In the Object Inspector window, click on the Display option and change the Opacity 
to 0.5.  Now rename the current version in Provenance Explorer to “Isosurface 3”. 

11. In the Provenance Explorer Plugin, go to Tools - Compute Statistics.  The name of 
the user, active time and total time will be shown in the pop-up window.

12. In the Provenance Explorer Plugin, go to Tools - Compute Sequence Statistics.  Se-
lect the “Apply” version for the start version and “Isosurface 3” version for the end 
version.  The user, active time, and total time will be shown in the pop-up window.

13. In the Provenance Explorer Plugin, go to Tools  and select Playback.  
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To play first select the Select Versions              and select the first and end version 

followed by the play icon.
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